2019-05-24, 01:23 AM
(2019-05-23, 07:11 PM)Manyula Wrote: I understand that the prefix is there to be able to quickly identify the module it belongs to, but imho I don't think that's necessary. But then again, I think this comes down to personal taste.
One more thing: I think some of the timer functions lack a certain consistency in terms of naming.
Code:native Timer_Get[b]Time[/b][i]Remaining[/i](Timer:timer);
native Timer_Get[b]Calls[/b][i]Remaining[/i](Timer:timer);
should be...
Code:native Timer_Get[i]Remaining[/i][b]Time[/b](Timer:timer);
native Timer_Get[i]Remaining[/i][b]Calls[/b](Timer:timer);
to be in line with...
Code:native Timer_GetTotalCalls(Timer:timer);
as the latter sounds more natural.
You're right about the mixed verb/noun order, I'll fix that.
As for module prefixes, that's now quite well established. It gives a nice consistent naming scheme, and there's a longer-term goal you'll have to wait for to see...